% IP addresses may not be configured on L2 links (CISCO)

PROBLEMUnable to configure IP on the specific interface.
SOLUTIONCreating VLAN with IP and assign VLAN to the physical interface.

[?] What is VLAN?
https://www.lifewire.com/virtual-local-area-network-817357

//create VLAN and assign IP to it

Router(config)# interface Vlan 10
Router(config-if)# ip address 172.16.0.1 255.255.255.0

//assign VLAN to interface

Router(config)# interface FastEthernet0/1
Router(config-if)# switchport mode access
Router(config-if)# switchport access Vlan 10

OUTPUT

Router(config)#sh ip int br
Vlan10 10.0.0.1 YES manual up down

Copy & Paste

conf t
interface Vlan 10
ip address 172.16.0.1 255.255.255.0
exit
interface FastEthernet0/1
switchport mode access
switchport access Vlan 10
end

Credit: https://www.experts-exchange.com/questions/21986774/IP-addresses-may-not-be-configured-on-L2-links-on-Cisco-1801.html

Leave a Reply

Your email address will not be published. Required fields are marked *